rip如何实现与ospf的通信

  • A+
所属分类:思科教程

之前我们学习了思科的动态路由,这种路由协议,一般应用于中小型架构。后来,我们又了解ospf路由协议,这种协议一般用于大型网络。那么如何让这两种网络通信!

相比ospf的区域宣告,动态路由使用全网宣告,这两个矛盾体如何实现通信?今天我们就来学习下路由重定向。

首先需要对照《思科动态路由》以及《简单聊ospf》教程配置下图,Router0和Router1使用的动态路由,剩下路由使用的ospf协议,其中Router2和Router3的f0/0都是area 0,Router3的f0/1口、Router4和Router5都是area 1。注意其中的Router1不用配置:

rip如何实现与ospf的通信

接下来我们配置Router1,实现rip和ospf的数据整合。

Continue with configuration dialog? [yes/no]: no
Router>enable
Router#configure terminal
Router(config)#interface FastEthernet0/0
Router(config-if)#no shutdown
Router(config-if)#ip address 192.168.2.2 255.255.255.0
Router(config-if)#exit
Router(config)#interface FastEthernet0/1
Router(config-if)#no shutdown
Router(config-if)#ip address 192.168.3.1 255.255.255.0
Router(config-if)#exit
Router(config)#router rip
Router(config-router)#network 192.168.2.0
Router(config-router)#exit
Router(config)#router ospf 1111
Router(config-router)#network 192.168.3.0 0.0.0.255 area 0
Router(config-router)#exit
Router(config)#route rip
Router(config-router)#redistribute ospf 1111 metric 2
Router(config-router)#exit
Router(config)#router ospf 1111
Router(config-router)#redistribute rip subnets

通过以上命令,我们可以发现,在做重定向时,需要在连接的路由器上,同时配置动态路由和ospf。

最后我们测试一下,首先是ping:

rip如何实现与ospf的通信

然后是show ip route:

rip如何实现与ospf的通信

  • 问答中心
  • 微信小程序扫一扫
  • weinxin
  • 微信公众
  • 微信公众号扫一扫
  • weinxin

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: