动态网络地址转换

  • A+
所属分类:思科教程

在之前的教程中我们学习了网络地址转换。我们可以发现,这种转换是一对一转换形式,如果内网中有多个终端如何解决?今天我们学习一下动态网络地址转换。

动态网络地址转换

首先我们需要配置一下网络环境,如图配置好每台设备的网络地址,其中R1路由器的f1/0端口需要设置多IP,还需在此端口设置默认路由:

R1#configure terminal
R1(config)#interface fastEthernet 0/0
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface fastEthernet 1/0
R1(config-if)#ip address 1.1.1.2 255.255.255.0
R1(config-if)#ip address 1.1.1.3 255.255.255.0 secondary
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#ip route 0.0.0.0 0.0.0.0 fastEthernet 1/0

接下来我们设置R2路由,无需过多设置,简单配置各端口IP即可:

R2#configure terminal
R2(config)#interface fastEthernet 0/0
R2(config-if)#ip address 1.1.1.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface fastEthernet 1/0
R2(config-if)#ip address 2.2.2.1 255.255.255.0
R2(config-if)#no shutdown

然后我们开始设置动态网络地址转换:

R1(config)#access-list 1 permit 192.168.1.0 0.0.0.255
R1(config)#ip nat pool cjk 1.1.1.2 1.1.1.3 netmask 255.255.255.0
R1(config)#ip nat inside source list 1 pool cjk
R1(config)#interface fastEthernet 0/0
R1(config-if)#ip nat inside
R1(config-if)#exit
R1(config)#interface fastEthernet 1/0
R1(config-if)#ip nat outside

最后测试一下:

动态网络地址转换

C1已经可以和C3通信了,那C2是否可以?我们在R2上加入ACL限制C2的地址:

R2(config)#access-list 1 deny host 192.168.1.3
R2(config)#access-list 1 permit any
R2(config)#interface fastEthernet 0/0
R2(config-if)#ip access-group 1 in

然后再测试C2去PING通C3:

动态网络地址转换

我们查看的NAT列表:

动态网络地址转换

  • 问答中心
  • 微信小程序扫一扫
  • weinxin
  • 微信公众
  • 微信公众号扫一扫
  • weinxin

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen:

上传图片

目前评论:1   其中:访客  1   博主  0

    • avatar firtukloimutrzas

      Wonderful paintings! That is the kind of information that are supposed to be shared around the internet. Shame on the search engines for no longer positioning this post higher! Come on over and consult with my web site . Thank you =)