思科策略路由

  • A+
所属分类:思科教程

两点之间直线最短,故图中R1如果与R4通信,只通过R2路由是最快的。但今天我们任性下,让数据包经过R3路由器,再发往R4。

思科策略路由

我们需要数据包的发送走向:

  1. 192.168.1.2
  2. 192.168.2.2
  3. 192.168.3.2
  4. 192.168.4.2

我们需要数据包的接受走向:

  1. 192.168.3.1
  2. 192.168.1.1

首先我们需要配置基础网络环境,实现全网连通。配置如下(仅以R4路由器为例)

R4#configure terminal
R4(config)#interface lo0
R4(config-if)#ip address 2.2.2.2 255.255.255.0
R4(config-if)#exit
R4(config)#interface fastEthernet 0/0
R4(config-if)#ip address 192.168.4.2 255.255.255.0
R4(config-if)#no shutdown
R4(config-if)#exit
R4(config)#router rip
R4(config-router)#network 2.2.2.0
R4(config-router)#network 192.168.4.0

然后我们测试一下网络的连通性,通过traceroute命令可以看得出,路由先通过192.168.1.2,然后是192.168.4.2。

思科策略路由

接下来我们修改一下数据包走向。通过拓扑我们可以判断,数据包在R2路由器需要转变方向,发送给R3,所以我们在R2路由进行如下配置:

R2(config)#access-list 100 permit ip host 1.1.1.1 host 2.2.2.2
R2(config)#route-map p1 permit 10
R2(config-route-map)#match ip address 100
R2(config-route-map)#set ip next-hop 192.168.2.2
R2(config-route-map)#exit
R2(config)#interface fastEthernet 0/0
R2(config-if)#ip policy route-map p1

看下数据包的走向:

思科策略路由

可以看出,数据包发向R2,但是路线并不是期望的那样,第三路线并不是192.168.3.2。我们需要在R3上配置下:

R3(config)#access-list 100 permit ip host 1.1.1.1 host 2.2.2.2
R3(config)#route-map p2 permit 10
R3(config-route-map)#match ip address 100
R3(config-route-map)#set ip next-hop 192.168.3.2
R3(config-route-map)#exit
R3(config)#interface fastEthernet 0/0
R3(config-if)#ip policy route-map p2

再次查看一下数据包的走向:

思科策略路由

最后说下策略路由应用。比如说你的路由有两个出口,分别连接电信路由、网通路由,就可以用策略路由实现,当你访问网通网络会走网通路由,访问电信网络会走电信路由!

  • 问答中心
  • 微信小程序扫一扫
  • weinxin
  • 微信公众
  • 微信公众号扫一扫
  • weinxin

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen:

目前评论:31   其中:访客  31   博主  0

    • avatar Digital Marketing Agency

      Leading Digital Marketing agency in India and Kolkata, Leading Web Design company. Providing web designing and Digital marketing services, Digital marketing course, and certification with an internship.